API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserDefinedElement Constructor (String, FontAttributes)

Creates a new user-defined element instance with the given name and font.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public UserDefinedElement(
	string Name,
	FontAttributes Font
)

Parameters

Name
Type: SystemString
The name to be used.
Font
Type: Tekla.Structures.DrawingFontAttributes
The font to be used.
See Also