![]() | TextFileTextFileAttributes Class |
The TextFileAttributes class contains the attributes for the text file object.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingEmbeddedObjectAttributes
Tekla.Structures.DrawingTextFileTextFileAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingEmbeddedObjectAttributes
Tekla.Structures.DrawingTextFileTextFileAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The TextFileTextFileAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | TextFileTextFileAttributes |
Creates a new text file attributes instance that loads standard attributes.
|

Name | Description | |
---|---|---|
![]() | Font |
Gets or sets the font.
|
![]() | Frame |
Gets or sets the frame.
(Inherited from EmbeddedObjectAttributes.) |
![]() | Line |
Gets or sets the line type.
|
![]() | LineType | Obsolete. |
![]() | Scaling |
Gets or sets the scaling.
|
![]() | XScale |
Gets or sets the X scaling value. Changing this property
will set the scaling type to ScaleXY.
(Inherited from EmbeddedObjectAttributes.) |
![]() | YScale |
Gets or sets the Y scaling value. Changing this property
will set the scaling type to ScaleXY.
(Inherited from EmbeddedObjectAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides EmbeddedObjectAttributesIsEqual(Object).) |
![]() | LoadAttributes |
Loads the specified attribute file.
(Overrides EmbeddedObjectAttributesLoadAttributes(String).) |