API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TextFile Constructor (ViewBase, Point, String, TextFileTextFileAttributes)

Creates a new text file instance using specific attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public TextFile(
	ViewBase view,
	Point insertionPoint,
	string fileName,
	TextFileTextFileAttributes attributes
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view for the object.
insertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location of the object.
fileName
Type: SystemString
The name of the referenced text file.
attributes
Type: Tekla.Structures.DrawingTextFileTextFileAttributes
The text file attributes to be used.
See Also