API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TextElement Constructor (String, FontAttributes)

Creates a new text element instance with the given textual value and font.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public TextElement(
	string Text,
	FontAttributes Font
)

Parameters

Text
Type: SystemString
The textual value to be used.
Font
Type: Tekla.Structures.DrawingFontAttributes
The font to be used.
See Also