API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TextElement Class

The TextElement class defines a user-defined text in a mark content.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class TextElement : ElementBase

The TextElement type exposes the following members.

Constructors
  NameDescription
Public methodTextElement(String)
Creates a new text element instance with the given textual value.
Public methodTextElement(String, FontAttributes)
Creates a new text element instance with the given textual value and font.
Top
Properties
  NameDescription
Public propertyFont
The font of the text element.
Public propertyValue
The textual value of the text element.
Top
Methods
See Also