![]() | TextTextAttributes Class |
The TextAttributes class is the attributes class for the text.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The TextTextAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | TextTextAttributes |
Creates a new default text attributes instance that loads standard attributes.
|
![]() | TextTextAttributes(String) |
Creates a new text attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | Alignment |
The text object's alignment (left, center, right).
|
![]() | Angle |
The angle of the text frame.
|
![]() | ArrowHead |
The arrowhead of the leader line.
|
![]() | CustomPresentation |
Custom presentation GUID to be applied to the object type
|
![]() | Font |
The text object's font settings.
|
![]() | Frame |
The frame for the text.
|
![]() | PlacingAttributes |
The placing attributes that the object should use.
Using these you can specify whether the object is automatically arranged in the drawing or not.
|
![]() | PreferredPlacing |
The type of placing the object should use.
See the preferred placing types for different types of placing.
|
![]() | RulerWidth |
Gets or sets the width in paper coordinates of the ruler to be used in word wrapping.
|
![]() | TransparentBackground |
Gets or sets a value indicating whether the background transparency is enabled for texts.
|
![]() | UseWordWrapping |
Gets or sets a value indicating whether to [use word wrapping].
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |