API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresDrawingsApplicationException Class

The TeklaStructuresDrawingsApplicationException class defines the base class for all exceptions that can be thrown while using Tekla.Structures.Drawing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class TeklaStructuresDrawingsApplicationException : ApplicationException

The TeklaStructuresDrawingsApplicationException type exposes the following members.

Constructors
  NameDescription
Public methodTeklaStructuresDrawingsApplicationException
Creates a new exception instance.
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemException
    SystemApplicationException
      Tekla.Structures.DrawingTeklaStructuresDrawingsApplicationException
        Tekla.Structures.DrawingCannotCreateSectionViewFrom3dView
        Tekla.Structures.DrawingCannotDeleteActiveDrawingException
        Tekla.Structures.DrawingCannotGetAttributeForPluginDueToIncorrectTypeException
        Tekla.Structures.DrawingCannotGetAttributeForPluginDueToInexistantFieldException
        Tekla.Structures.DrawingCannotGetAttributeForPluginException
        Tekla.Structures.DrawingCannotInsertDrawingException
        Tekla.Structures.DrawingCannotLoadAttributesException
        Tekla.Structures.DrawingCannotModifyNonActiveDrawingException
        Tekla.Structures.DrawingCannotPerformOperationDrawingEditorMustBeClosedException
        Tekla.Structures.DrawingCannotPerformOperationDrawingIsActiveException
        Tekla.Structures.DrawingCannotPerformOperationDrawingMustBeActiveException
        Tekla.Structures.DrawingCannotPerformOperationDrawingNotUpToDateException
        Tekla.Structures.DrawingCannotPerformOperationNumberingNotUpToDate
        Tekla.Structures.DrawingCannotSetAttributeForPluginDueToIncorrectTypeException
        Tekla.Structures.DrawingCannotSetAttributeForPluginDueToInexistantFieldException
        Tekla.Structures.DrawingCannotSetAttributeForPluginException
        Tekla.Structures.DrawingInvalidAttributesForOperationException
        Tekla.Structures.DrawingInvalidPluginPickerInputException
        Tekla.Structures.DrawingInvalidTypeException
        Tekla.Structures.DrawingPickerInterruptedException
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.