API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SymbolLibraryGetSymbolLibraries Method (Boolean)

Gets the names of the available symbol files in the current Tekla Structures environment, in the "symbols" directory, without the suffix.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static StringList GetSymbolLibraries(
	bool forceRefresh
)

Parameters

forceRefresh
Type: SystemBoolean
If set to true, always lists the files again (slower).

Return Value

Type: StringList
A list of symbol file names or null if failed.
See Also