API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SymbolInfo Constructor (String, Int32)

Creates a new symbol info instance.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public SymbolInfo(
	string SymbolFile,
	int SymbolIndex
)

Parameters

SymbolFile
Type: SystemString
The symbol file to be used.
SymbolIndex
Type: SystemInt32
The symbol index to be used.
Exceptions
ExceptionCondition
ArgumentOutOfRangeExceptionThrown if the symbol index is invalid.
See Also