![]() | SymbolInfo Class |
The SymbolInfo class holds symbol information: the symbol file and the symbol index in the symbol file.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The SymbolInfo type exposes the following members.

Name | Description | |
---|---|---|
![]() | SymbolInfo |
Creates a new symbol info instance.
|
![]() | SymbolInfo(String, Int32) |
Creates a new symbol info instance.
|

Name | Description | |
---|---|---|
![]() | SymbolFile |
Gets or sets the symbol file. E.g. "xsteel".
|
![]() | SymbolIndex |
Gets or sets the the symbol index. Throws an ArgumentOutOfRangeException
if the symbol index is not in the range from 0 to 255.
|