API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SymbolElement Constructor (SymbolInfo, DrawingColors, Double)

Creates a new symbol element instance with the given symbol, color and height.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public SymbolElement(
	SymbolInfo Symbol,
	DrawingColors Color,
	double Height
)

Parameters

Symbol
Type: Tekla.Structures.DrawingSymbolInfo
The symbol to be used.
Color
Type: Tekla.Structures.DrawingDrawingColors
The symbol color to be used.
Height
Type: SystemDouble
The symbol height (mm) to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.