API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SymbolElement Constructor (SymbolInfo)

Creates a new symbol element instance with the given symbol.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public SymbolElement(
	SymbolInfo Symbol
)

Parameters

Symbol
Type: Tekla.Structures.DrawingSymbolInfo
The symbol to be used.
See Also