![]() | SymbolSymbolAttributes Class |
The SymbolAttributes class contains the attributes for the symbol.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The SymbolSymbolAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | SymbolSymbolAttributes |
Creates a new default symbol attributes instance that loads standard attributes.
|
![]() | SymbolSymbolAttributes(String) |
Creates a symbol attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | Angle |
The angle of the symbol. Cannot be changed for an
editor-created symbol when the symbol is created "along line".
|
![]() | Color |
The symbol color. Does not have an effect on symbols
where the color is already defined in the symbol file.
|
![]() | Frame |
The frame for the symbol.
|
![]() | Height |
The height of the symbol.
|
![]() | PreferredPlacing |
The type of placing the object should use.
See the preferred placing types for different types of placing.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |