API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Symbol Constructor (ViewBase, Point, SymbolInfo, PlacingBase)

Creates a new symbol instance using standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Symbol(
	ViewBase View,
	Point InsertionPoint,
	SymbolInfo SymbolInfo,
	PlacingBase Placing
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view where to insert the symbol.
InsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location where to place the symbol.
SymbolInfo
Type: Tekla.Structures.DrawingSymbolInfo
The symbol information to be used.
Placing
Type: Tekla.Structures.DrawingPlacingBase
The way the object is placed.
See Also