API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Symbol Constructor (ViewBase, Point)

Creates a new symbol instance using the default symbol information and standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Symbol(
	ViewBase View,
	Point InsertionPoint
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view where to insert the symbol.
InsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location where to place the symbol.
See Also