![]() | SurfacingSurfacingAttributes Class |
The SurfacingAttributes class is the attributes class for the surfacing.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingSurfacingSurfacingAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingSurfacingSurfacingAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The SurfacingSurfacingAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | SurfacingSurfacingAttributes |
Creates a new default surfacing attributes instance that loads standard attributes.
|
![]() | SurfacingSurfacingAttributes(String) |
Creates a new surfacing attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | DrawHiddenLines |
True if hidden lines are drawn.
|
![]() | DrawOwnHiddenLines |
True if own hidden lines are enabled.
|
![]() | HiddenLines |
The line type of hidden lines.
|
![]() | Representation |
The representation type of the surfacing.
|
![]() | ShowPattern |
True if the pattern is shown.
|
![]() | VisibleLines |
The line type of visible lines.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |