API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StringListLastIndexOf Method (String, Int32)

Searches for the last occurence of the string in the list.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public int LastIndexOf(
	string value,
	int startIndex
)

Parameters

value
Type: SystemString
The string to locate.
startIndex
Type: SystemInt32
The index to start the search from.

Return Value

Type: Int32
The last index of the string if found, otherwise -1.
See Also