API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StraightDimensionSetHandler Class

The StraightDimensionSetHandler class contains operations for creating and modifying straight dimension sets.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingStraightDimensionSetHandler

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class StraightDimensionSetHandler

The StraightDimensionSetHandler type exposes the following members.

Constructors
  NameDescription
Public methodStraightDimensionSetHandler
Initializes a new instance of the StraightDimensionSetHandler class
Top
Methods
  NameDescription
Public methodCreateDimensionSet(ViewBase, PointList, Vector, Double)
Creates straight dimensions and combines them to one straight dimension set. Returns null if fails.
Public methodCreateDimensionSet(ViewBase, PointList, Vector, Double, StraightDimensionSetStraightDimensionSetAttributes)
Creates straight dimensions and combines them to one straight dimension set. Returns null if fails.
Public methodCreateDimensionSet(ViewBase, PointList, Vector, Double, Double, Double)
Creates straight dimensions and combines them to one straight dimension set. Returns null if fails.
Public methodCreateDimensionSet(ViewBase, PointList, Vector, Double, Double, Double, StraightDimensionSetStraightDimensionSetAttributes)
Creates straight dimensions and combines them to one straight dimension set. Returns null if fails.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.