API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StraightDimensionSetStraightDimensionSetAttributesLoadAttributes Method

Loads the attributes from the attribute file.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public override bool LoadAttributes(
	string attributeFilename
)

Parameters

attributeFilename
Type: SystemString
The filename of the attribute file.

Return Value

Type: Boolean
True if the attributes are loaded correctly. False if the attribute file loading failed.
See Also