API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StraightDimensionSetStraightDimensionSetAttributes Constructor (String)

Note: This API is now obsolete.

Creates a straight dimension set attributes instance that loads the specified attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[ObsoleteAttribute("This constructor is obsolete and may be removed in the future. Instead, use the constructor which takes a ModelObject and a string.", 
	false)]
public StraightDimensionSetAttributes(
	string AttributesFile
)

Parameters

AttributesFile
Type: SystemString
The filename of the attributes file.
See Also