![]() | StraightDimensionStraightDimensionAttributes Class |
The StraightDimensionAttributes class contains the attributes of the straight dimension.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingStraightDimensionStraightDimensionAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingStraightDimensionStraightDimensionAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The StraightDimensionStraightDimensionAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | StraightDimensionStraightDimensionAttributes | Initializes a new instance of the StraightDimensionStraightDimensionAttributes class |

Name | Description | |
---|---|---|
![]() | DimensionValuePostfix |
The postfix for the dimension's value.
|
![]() | DimensionValuePrefix |
The prefix for the dimension's value.
|
![]() | Exaggeration |
The exaggeration attributes of the dimension.
|
![]() | MiddleLowerTag |
The dimension tag placed under the dimension value.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
The attributes can't be loaded.
(Overrides AttributesBaseLoadAttributes(String).) |