API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StraightDimensionGetDimensionSet Method (Boolean)

Gets the dimension set the current dimension belongs to.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public override DimensionSetBase GetDimensionSet(
	bool Select
)

Parameters

Select
Type: SystemBoolean
Whether to select the object from the database or not.

Return Value

Type: DimensionSetBase
The dimension set the current dimension belongs to.
See Also