API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StraightDimension Constructor (ViewBase, Point, Point, Vector, Double, StraightDimensionSetStraightDimensionSetAttributes)

Initializes a new instance of the StraightDimension class.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public StraightDimension(
	ViewBase targetView,
	Point startPoint,
	Point endPoint,
	Vector upDirection,
	double distance,
	StraightDimensionSetStraightDimensionSetAttributes attributes
)

Parameters

targetView
Type: Tekla.Structures.DrawingViewBase
The target view of the dimension.
startPoint
Type: Tekla.Structures.Geometry3dPoint
The start point of the dimension.
endPoint
Type: Tekla.Structures.Geometry3dPoint
The end point of the dimension.
upDirection
Type: Tekla.Structures.Geometry3dVector
The up direction.
distance
Type: SystemDouble
The height of the dimension.
attributes
Type: Tekla.Structures.DrawingStraightDimensionSetStraightDimensionSetAttributes
The dimension attributes.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.