API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Size Class

The Size class contains the width and height properties.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingSize

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class Size

The Size type exposes the following members.

Constructors
  NameDescription
Public methodSize
Creates a new size instance with zero width and height.
Public methodSize(Double, Double)
Creates a new size instance with the specified width and height.
Top
Properties
  NameDescription
Public propertyHeight
Gets or sets the height value of the size instance.
Public propertyWidth
Gets or sets the width value of the size instance.
Top
Methods
  NameDescription
Public methodCode exampleToString
Returns a string that represents this instance (in fractional inches if advanced option XS_USE_ONLY_INCHES_IN_SHEET_SIZES set to true).
(Overrides ObjectToString.)
Public methodCode exampleToString(String)
Returns a string that represents this instance (in fractional inches if advanced option XS_USE_ONLY_INCHES_IN_SHEET_SIZES set to true).
Public methodCode exampleToString(IFormatProvider, String)
Returns a string that represents this instance (in fractional inches if advanced option XS_USE_ONLY_INCHES_IN_SHEET_SIZES set to true).
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.