API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SinglePartDrawing Constructor (Identifier, String)

Instantiates a new single part drawing with given attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public SinglePartDrawing(
	Identifier partIdentifier,
	string AttributeFile
)

Parameters

partIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the model object part
AttributeFile
Type: SystemString
The filename of the attributes file.
See Also