API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SinglePartDrawing Constructor (Identifier, Int32)

Instantiates a new single part drawing with standard attributes and with a specified sheet number.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public SinglePartDrawing(
	Identifier partIdentifier,
	int sheetNumber
)

Parameters

partIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the model object part
sheetNumber
Type: SystemInt32
The sheet number of the drawing.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.