![]() | SectionMarkBaseSectionMarkTagAttributes Class |
The SectionMarkTagAttributes class contains attributes for section mark tags.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewMarkBasicTagAttributes
Tekla.Structures.DrawingSectionMarkBaseSectionMarkTagAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewMarkBasicTagAttributes
Tekla.Structures.DrawingSectionMarkBaseSectionMarkTagAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The SectionMarkBaseSectionMarkTagAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | SectionMarkBaseSectionMarkTagAttributes |
Creates a new section mark tag attributes instance.
|
![]() | SectionMarkBaseSectionMarkTagAttributes(SectionMarkBaseSectionMarkTagAttributesTagShowOnSide, TagLocation, Vector, SectionMarkBaseSectionMarkTagAttributesTagTextRotation, ContainerElement) |
Creates a new section mark tag attributes instance with the given information.
|

Name | Description | |
---|---|---|
![]() | Location |
The location of the mark tag.
(Inherited from ViewMarkBasicTagAttributes.) |
![]() | Offset |
The offset of the mark tag.
(Inherited from ViewMarkBasicTagAttributes.) |
![]() | ShowOnSide |
The side(s) on which the tag is shown.
|
![]() | TagContent |
The tag content.
(Inherited from ViewMarkBasicTagAttributes.) |
![]() | TagRotation |
The policy for the tag rotation.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides ViewMarkBasicTagAttributesIsEqual(Object).) |