API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SectionMarkBaseSectionMarkSymbolSymbolShapes Enumeration

The possible shapes of the section mark symbol.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public enum SymbolShapes
Members
  Member nameValueDescription
None1 No symbol.
SymbolShape1101 The triangle with black and white halves.
SymbolShape2102 The arrow line pointing to an orthogonal straight line.
SymbolShape3103 The line with half of an arrow end.
SymbolShape4104 The rectangle shape with very small height.
SymbolShape5105 The triangle and circle shapes mixed. The circle partly hides the triangle.
SymbolShape6106 The triangle and circle shapes mixed. The triangle is on top.
SymbolShape7107 The triangle shape without content.
SymbolShape8108 The triangle shape filled in black.
Custom4 The custom shape.
See Also