API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SectionMarkBaseSectionMarkSymbol Constructor (SectionMarkBaseSectionMarkSymbolSymbolShapes, Double, Point)

Creates a new section mark symbol instance with the given shape, size and position.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public SectionMarkSymbol(
	SectionMarkBaseSectionMarkSymbolSymbolShapes shape,
	double size,
	Point position
)

Parameters

shape
Type: Tekla.Structures.DrawingSectionMarkBaseSectionMarkSymbolSymbolShapes
The shape of the section mark symbol to be used.
size
Type: SystemDouble
The size of the section mark symbol to be used.
position
Type: Tekla.Structures.Geometry3dPoint
The position of the section mark symbol to be used.
See Also