![]() | SectionMarkBaseSectionMarkSymbol Class |
The SectionMarkSymbol class is for section mark attributes related to the shape of the connecting symbol.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingSectionMarkBaseSectionMarkSymbol
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingSectionMarkBaseSectionMarkSymbol
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The SectionMarkBaseSectionMarkSymbol type exposes the following members.

Name | Description | |
---|---|---|
![]() | SectionMarkBaseSectionMarkSymbol |
Creates a new section mark symbol instance.
|
![]() | SectionMarkBaseSectionMarkSymbol(SectionMarkBaseSectionMarkSymbolSymbolShapes, Double, Point) |
Creates a new section mark symbol instance with the given shape, size and position.
|

Name | Description | |
---|---|---|
![]() | Position |
The position of the section mark symbol.
|
![]() | Shape |
The shape of the section mark symbol.
|
![]() | Size |
The size of the section mark symbol.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |