SectionMark Class

The SectionMark class defines a drawing object that illustrates a straight section in a specific view.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class SectionMark : SectionMarkBase

The SectionMark type exposes the following members.

Constructors
  NameDescription
Public methodSectionMark(View, Point, Point)
Creates a new section mark instance with the given positions.
Public methodSectionMark(View, Point, Point, SectionMarkBaseSectionMarkAttributes)
Creates a new section mark instance with the given positions and attributes.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Top
Examples
The following code inserts a new section mark in the current drawing:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class SectionMarkExample
{
    public void SectionMarkInsert()
    {
        DrawingHandler myDrawingHandler = new DrawingHandler();
        DrawingObjectEnumerator viewsEnumerator = myDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews();
        View view = null;
        if (viewsEnumerator.MoveNext())
            view = viewsEnumerator.Current as View;

        if (view != null)
        {
            SectionMark sectionMark = new SectionMark(view, new Point(1000, 2000), new Point(3000, 1200));
            sectionMark.Insert();
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next