API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReportTemplateElement Constructor (TemplateInfo)

Creates a new report template element instance with the given template.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public ReportTemplateElement(
	TemplateInfo Template
)

Parameters

Template
Type: Tekla.Structures.DrawingTemplateInfo
The template to be used.
See Also