API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReinforcementPulloutElement Class

The ReinforcementPulloutElement class illustrates the shape and dimensions of a reinforcing bar in a drawing.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingElementBase
    Tekla.Structures.DrawingReinforcementPulloutElement

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class ReinforcementPulloutElement : ElementBase

The ReinforcementPulloutElement type exposes the following members.

Constructors
  NameDescription
Public methodReinforcementPulloutElement
Creates a new reinforcement pull-out element instance.
Top
Properties
  NameDescription
Public propertyAutomaticScaling
Gets or sets a value indicating whether the pull-out is scaled automatically or to a specified value.
Public propertyBendingAngle
Gets or sets a value indicating whether to show the pull-out bending angles.
Public propertyBendingRadius
Gets or sets a value indicating whether to show the pull-out bending radii.
Public propertyCouplersEndAnchorSymbols
Gets or sets a value indicating whether to show coupler/anchor symbols or not.
Public propertyCouplersScale
Gets or sets the scale of coupler/anchor symbols.
Public propertyDimensioning
Gets or sets a value indicating whether to show the pull-out dimensions.
Public propertyEndSymbolType
Gets or sets the type of the ending marks.
Public propertyExaggeration
Gets or sets a value indicating whether the pull-out is exaggerated.
Public propertyFont
Gets or sets the font of the dimension.
Public propertyRotationAxis
Gets or sets the rotation of the pull-out.
Public propertyScaleX
Gets or sets the scaling of the pull-out in the X direction.
Public propertyScaleY
Gets or sets the scaling of the pull-out in the Y direction.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.