API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReinforcementBaseStraightEndSymbolTypes Enumeration

The available straight end symbol types. See Tekla Structures help, "Reinforcement appearance", for more information.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public enum StraightEndSymbolTypes
Members
  Member nameValueDescription
NoSymbol1No straight end symbol.
HooksOnInnerSide2Draws half hooks on the reinforcement's inner side.
HooksOnOuterSide3Draws half hooks on the reinforcement's outer side.
HookOnReinforcementStartOuterSide4 Draws a half hook on the reinforcement's outer side in the reinforcement's start point, and another half hook on the inner side in the end point.
HookOnReinforcementStartInnerSide5 Draws a half hook on the reinforcement's inner side in the reinforcement's start point, and another half hook on the outer side in the end point.
FullHooks6Draws full hooks in the reinforcement's end points.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.