API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReinforcementBaseReinforcementVisibilityTypes Enumeration

The available reinforcement visibility types. Only applies to bar groups and meshes. See Tekla Structures help, "Setting the visibility of reinforcement in drawings", for more information.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public enum ReinforcementVisibilityTypes
Members
  Member nameValueDescription
All1Shows all bars in a group or mesh.
First2Only shows the first bar in the group or mesh.
Last3Only shows the last bar in the group or mesh.
FirstAndLast4Shows the first and last bar in the group or mesh.
OneInTheMiddle5Shows one bar in the middle of the group or mesh.
TwoInTheMiddle6Shows two bars in the middle of the group or mesh.
Customized7Indicates that you have specified the location of the only visible reinforcing bar. See "Adjusting reinforcing bars" in the Tekla Structures help for more information.
See Also