![]() | ReinforcementBaseReinforcementMeshAttributes Class |
The ReinforcementMeshAttributes class is the base attributes class for ReinforcementMesh.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementMeshAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementMeshAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ReinforcementBaseReinforcementMeshAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | ReinforcementBaseReinforcementMeshAttributes |
Creates a new default reinforcement attributes instance that loads standard attributes.
|
![]() | ReinforcementBaseReinforcementMeshAttributes(Boolean) |
Creates a new default reinforcement attributes instance that loads standard attributes.
If it set to true attributes won't be lodaded. |
![]() | ReinforcementBaseReinforcementMeshAttributes(String) |
Creates a new reinforcement attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | CustomPresentation |
Custom presentation GUID to be applied to the object type
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | HiddenLines |
The line type of the hidden lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | HideLinesHiddenByPart |
Defines whether lines hidden by parts should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | HideLinesHiddenByReinforcement |
Defines whether lines hidden by reinforcements should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | MeshReinforcementSymbolIndex |
Defines the index for the mesh symbol to be used.
The mesh symbol appears in the middle of the mesh line when ReinforcementRepresentation == OutLine.
The index starts from 0 and corresponds to the symbol in the file mesh.sym.
|
![]() | MeshReinforcementSymbolSize |
Defines the size of the reinforcement mesh symbol.
|
![]() | MeshReinforcementVisibilityCrossing |
Defines which crossing bars in the mesh appear in drawings.
|
![]() | MeshReinforcementVisibilityLongitudinal |
Defines which longitudinal wires in the mesh appear in drawings.
|
![]() | ReinforcementRepresentation |
The representation of reinforcing bars.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | VisibleLines |
The line type of the visible lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides ReinforcementBaseReinforcementBaseAttributesIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |