![]() | ReinforcementBaseReinforcementGroupAttributes Class |
The ReinforcementGroupAttributes class is the base attributes class for
ReinforcementGroup.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementGroupAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementGroupAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ReinforcementBaseReinforcementGroupAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | ReinforcementBaseReinforcementGroupAttributes |
Creates a new default reinforcement attributes instance that loads standard attributes.
|
![]() | ReinforcementBaseReinforcementGroupAttributes(String) |
Creates a new reinforcement attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | CustomPresentation |
Custom presentation GUID to be applied to the object type
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | HiddenLines |
The line type of the hidden lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | HideLinesHiddenByPart |
Defines whether lines hidden by parts should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | HideLinesHiddenByReinforcement |
Defines whether lines hidden by reinforcements should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | HookedEndSymbolType |
Defines how the hooked ends of reinforcing bars should look like.
|
![]() | ReinforcementRepresentation |
The representation of reinforcing bars.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
![]() | ReinforcementVisibility |
Defines which bars in the group appear in drawings.
|
![]() | StraightEndSymbolType |
Defines how the straight ends of reinforcing bars should look like.
|
![]() | VisibleLines |
The line type of the visible lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides ReinforcementBaseReinforcementBaseAttributesIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |