![]() | ReinforcementBaseReinforcementBaseAttributes Class |
The ReinforcementBaseAttributes class is the attributes class for the reinforcement.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementGroupAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementMeshAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementSetGroupAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementSingleAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementStrandAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementGroupAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementMeshAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementSetGroupAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementSingleAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementStrandAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ReinforcementBaseReinforcementBaseAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | CustomPresentation |
Custom presentation GUID to be applied to the object type
|
![]() | HiddenLines |
The line type of the hidden lines of the reinforcement.
|
![]() | HideLinesHiddenByPart |
Defines whether lines hidden by parts should be hidden or not.
|
![]() | HideLinesHiddenByReinforcement |
Defines whether lines hidden by reinforcements should be hidden or not.
|
![]() | ReinforcementRepresentation |
The representation of reinforcing bars.
|
![]() | VisibleLines |
The line type of the visible lines of the reinforcement.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |