API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Rectangle Constructor (ViewBase, Point, Double, Double)

Creates a new rectangle instance with the start point and the defined width and height using standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Rectangle(
	ViewBase view,
	Point startPoint,
	double width,
	double height
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
startPoint
Type: Tekla.Structures.Geometry3dPoint
The start point to be used.
width
Type: SystemDouble
The width to be used.
height
Type: SystemDouble
The height to be used.
See Also