![]() | RadiusDimension Class |
The RadiusDimension class defines a radius dimension that displays the radius of the given arc.

SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionBase
Tekla.Structures.DrawingRadiusDimension
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionBase
Tekla.Structures.DrawingRadiusDimension
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The RadiusDimension type exposes the following members.

Name | Description | |
---|---|---|
![]() | RadiusDimension(ViewBase, Point, Point, Point, Double) |
Creates a new radius dimension instance using three points and the distance.
|
![]() | RadiusDimension(ViewBase, Point, Point, Point, Double, RadiusDimensionAttributes) |
Creates a new radius dimension instance with the attributes, three points and the distance.
|

Name | Description | |
---|---|---|
![]() | ArcPoint1 |
Gets the first arc point.
|
![]() | ArcPoint2 |
Gets the second arc point.
|
![]() | ArcPoint3 |
Gets the third arc point.
|
![]() | Attributes |
The radius dimension attributes.
|
![]() | Distance |
Gets or sets the distance.
|
![]() | Hideable |
Accesses the information if this object is hidden or not or if it should be.
(Inherited from DimensionBase.) |
![]() | QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) |

Name | Description | |
---|---|---|
![]() | Delete |
Deletes the dimension from the database.
(Overrides DatabaseObjectDelete.) |
![]() | GetDimensionSet |
Radius dimensions don't have dimension sets.
(Overrides DimensionBaseGetDimensionSet.) |
![]() | GetDimensionSet(Boolean) |
Radius dimensions don't have dimension sets.
(Overrides DimensionBaseGetDimensionSet(Boolean).) |
![]() | GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) |
![]() | GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) |
![]() | GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) |
![]() | GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) |
![]() | Insert |
Inserts the dimension into the database.
(Overrides DatabaseObjectInsert.) |
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).) |
![]() | IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) |
![]() | Modify |
Modifies the existing dimension in the database.
(Overrides DatabaseObjectModify.) |
![]() | Select |
Selects the radius dimension from the database.
(Overrides DatabaseObjectSelect.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |

using Tekla.Structures.Drawing; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { DrawingHandler MyDrawingHandler = new DrawingHandler(); ViewBase _view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase; RadiusDimension basicDimension = new RadiusDimension(_view, new Point(-1000, 0, 0), new Point(0, 1000, 0), new Point(1000, 0, 0), 200); } }