API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PrintAttributes Class

The PrintAttributes class contains the attributes for controlling the printing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class PrintAttributes : GenericAttributesBase

The PrintAttributes type exposes the following members.

Constructors
  NameDescription
Public methodPrintAttributes
Creates a new PrintAttributes instance.
Top
Properties
  NameDescription
Public propertyNumberOfCopies
The number of copies in printing.
Public propertyOrientation
The print orientation type.
Public propertyPrintArea
The print area type.
Public propertyPrinterInstance
The name of the printer instance. Can be fetched from the printer catalog.
Public propertyPrintToMultipleSheet
Whether to print to multiple sheets.
Public propertyScale
The scale factor.
Public propertyScalingType
The scale type.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also