![]() | PreferredTextPlacingTypes Class |
The PreferredTextPlacingTypes class contains the available preferred text placing types.
These are allowed to be used for texts.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The PreferredTextPlacingTypes type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | AlongLinePlacingType |
The object is placed using the along line placing.
|
![]() ![]() | BaseLinePlacingType |
The object is placed using the base line placing.
|
![]() ![]() | BaseLineWithArrowAtEndPointPlacingType |
The object is placed using the base line placing.
The line is drawn and will have an arrow at the end point.
|
![]() ![]() | BaseLineWithArrowAtStartPointPlacingType |
The object is placed using the base line placing.
The line is drawn and will have an arrow at the start point.
|
![]() ![]() | LeaderLinePlacingType |
The object is placed with a leader line.
|
![]() ![]() | PointPlacingType |
The object is placed at one point (the insertion point) without any additional placing options.
|