API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PreferredPlacingTypesInsidePartHorizontalOrWithLeaderLinePlacingType Method

The object is placed using the base line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line. The base line used is in the middle of the part, aligned with the part. In addition the object will be rotated to be horizontal in the drawing.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static PreferredPlacingTypeBase InsidePartHorizontalOrWithLeaderLinePlacingType()

Return Value

Type: PreferredPlacingTypeBase
A new inside part horizontal or with leader line placing type instance.
See Also