API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PourObjectPourAttributes Class

The PourAttributes class is the attributes class for the pour.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingPourObjectPourAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class PourAttributes : AttributesBase

The PourObjectPourAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyDrawChamfers
True if chamfers are drawn.
Public propertyDrawHiddenLines
True if hidden lines are drawn.
Public propertyDrawOwnHiddenLines
True if own hidden lines are drawn.
Public propertyFaceHatch
The hatch type of the face hatch.
Public propertyHiddenLines
The line type of hidden lines.
Public propertySectionFaceHatch
The hatch type of the section face hatch.
Public propertyVisibleLines
The line type of visible lines.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.