![]() | PourBreakPourBreakAttributes Class |
The PourBreakAttributes class is the attributes class for the pour break.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingPourBreakPourBreakAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingPourBreakPourBreakAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The PourBreakPourBreakAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | PourBreakPourBreakAttributes |
Creates a new default pour break attributes instance that loads standard attributes.
|
![]() | PourBreakPourBreakAttributes(String) |
Creates a new pour break attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | DrawHiddenLines |
Indicates whether hidden lines are used to draw the pour break or not.
|
![]() | HiddenLines |
The hidden line type of the pour break.
|
![]() | VisibleLines |
The visible line type of the pour break.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |