API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolylinePolylineAttributes Class

The PolylineAttributes class is the attributes class of the polyline.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class PolylineAttributes : OpenGraphicObjectOpenGraphicObjectAttributes

The PolylinePolylineAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyArrowhead
The arrowhead attributes of the open graphic object. The end points of an open graphic object can contain arrowheads.
(Inherited from OpenGraphicObjectOpenGraphicObjectAttributes.)
Public propertyLine
The line attributes of the graphic object. A graphic object always consists of lines.
(Inherited from GraphicObjectGraphicObjectAttributes.)
Top
Methods
See Also