API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PointListLastIndexOf Method (Point, Int32, Int32)

Searches for the last occurence of the point in the list.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public int LastIndexOf(
	Point value,
	int startIndex,
	int count
)

Parameters

value
Type: Tekla.Structures.Geometry3dPoint
The point to locate.
startIndex
Type: SystemInt32
The index to start the search from.
count
Type: SystemInt32
The number of items searched.

Return Value

Type: Int32
The last index of the point if found, otherwise -1.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.