API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PointListIndexOf Method (Point)

Gets the index of the specified point.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public int IndexOf(
	Point value
)

Parameters

value
Type: Tekla.Structures.Geometry3dPoint
The point to locate in the list.

Return Value

Type: Int32
The index of the point if found in the list, otherwise -1.
See Also