API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginPickerInput Class

The PluginPickerInput class represents a predefined set of picker inputs that can be provided to a plug-in object. It replaces the interactive selection of points and/or objects by the user when the plug-in is inserted into a drawing through the API.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPluginPickerInput

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class PluginPickerInput

The PluginPickerInput type exposes the following members.

Constructors
  NameDescription
Public methodPluginPickerInput
Initializes a new instance of the PluginPickerInput class with an empty list of picker inputs.
Public methodPluginPickerInput(ListPickerInput)
Initializes a new instance of the PluginPickerInput class which contains a predefined sequence of inputs.
Top
Methods
  NameDescription
Public methodAdd
Appends a picker input to the plug-in input.
Public methodAddRange
Appends several picker inputs to the picker input sequence.
Top
See Also