API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginTrySetAttribute Method (String, Double)

Sets the specified attribute of the plug-in to the given value. NOTE! Only works on already inserted plug-ins.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool TrySetAttribute(
	string FieldName,
	double fieldValue
)

Parameters

FieldName
Type: SystemString
The name of the attribute to set.
fieldValue
Type: SystemDouble
The value for the attribute.

Return Value

Type: Boolean
True on success. Otherwise, false.
See Also